欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

6.0的sdk编译出的东西在5.0上跑摔了~解决方法

更新时间: 2014-01-05 02:42:52 责任编辑: Author_N1

 

6.0的SDK编译出的东西在5.0上跑摔了~~~~~
6.0的SDK下编译出的cod文件在9800上很OK~但是到了9700上就打不开了~~
报错如下:
Error starting :Class 'net.rim.device.api.ui.scrollview' not found.

调查了下ScrollView~
这货是6.0才有的API~但是在我的程序中从头到脚都没有用到过这玩意~~~
难道6.0自动给每个程序都添了?导致5.0的操作系统不支持?
难道以后6.0编译出的东西都不能在5.0上跑了?

求解~~~Orz

--参考方法--
是,5.0编译出来的就不能在4.5上跑
--参考方法--
只试过 从4.5编译后 在4.6 4.7 5.0跑
--参考方法--
神贴啊!

只听说向后兼容,没听说向前兼容。

只听说Windows XP能跑DOS的程序,没听说DOS上可以跑Windows程序。


--参考方法--
某些控件也许继承或者实现了一些OS5.0中不存在的类或接口。

招收手机开发精英,有兴趣的选消息
上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2014-01-05 02:42:52
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/13467/
本文WWW.DOC100.NET DOC100.NET版权所有。