欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

maven出现(请使用-source 5 或者更高版本以启用xx)问题解决 -

更新时间: 2015-05-03 00:00:00 责任编辑: Author_N12

 

  • 问题:maven在进行打包时,报 '请使用-source 5 或者更高版本以启用XX'的信息并导致打包失败。
  • 原因:maven默认的编译插件的java版本较低,导致其不支持例如泛型,注解等用法。
  • 解决方法:在项目的pom.xml文件中加入以下内容用来指定版本,配置如下:

<build>
    <pluginManagement>
      <plugins>
	<plugin>
	  <groupId>org.apache.maven.plugins</groupId>
	  <artifactId>maven-compiler-plugin</artifactId>
	  <configuration>
	    <source>1.6</source>
	    <target>1.6</target>
		<encoding>UTF-8</encoding>
	  </configuration>
	</plugin>
    </plugins>
   </pluginManagement> 
</build>
上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2015-05-03 00:00:00
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/1471862/
本文WWW.DOC100.NET DOC100.NET版权所有。