欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

wince6.0装置不能运行c

更新时间: 2014-01-05 03:10:12 责任编辑: Author_N1

 

WinCE6.0设备不能运行C#
WinCE6.0内核定制时添加了对CF2.0,CF3.5的支持,但是C#(CF2.0)程序不能再板子上运行,运行时报:

此应用程序需要比安装在此设备上的 Microsoft(R) .NET Compact Framework 更高的版本。

我从网上下载了CF3.5/CF2.0在设备上安装,安装时报“已安装了NETCF的较高版本,在安装此版本之前必须先卸载较高的版本。”这说明设备是有CF3.5的,但就是 不能运行C#。

在线等解决方法..........
--参考方法--
试一下只选择:.net compact framework 3.5
--参考方法--
引用:
试一下只选择:.net compact framework 3.5

按照错误提示应该是这个问题
--参考方法--
Wince允许安装多个版本的CF,似乎可以更好地支持各种版本的.net应用程序。
但如果真这样做了,可能就会如楼主这般悲催。
曾看到有人在微软的论坛发过这样的帖子,记得微软的建议是卸载CF

另外,用\Windows\cgacutil.exe命令查看CF版本号
看与你VS“解决方案管理器”引用中dll的CF版本是否匹配(VS2005也有可能用的CF3.5)
VS的版本至少不能高了。
上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2014-01-05 03:10:12
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/19080/
本文WWW.DOC100.NET DOC100.NET版权所有。