欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

关于硬件升级

更新时间: 2014-01-05 03:18:53 责任编辑: Author_N1

 

关于硬件升级求助!
   最近在开发一款和硬件相关的软件,对方是提供了sdk的,我这边开发着,突然去对方官网发现对方的sdk升级了,应该是对方开发出了新的设备,然后老大这边要我重新开发下子。

   我用vc6.0的depency看了下子新的dll,发现里面的函数都是相同的,我觉得我们这边貌似只用替换下子以前的dll就行了,程序代码什么的不用动,个人的想法是,既然对方新提供了设备,并且也提供了新的sdk,我们这款软件如果买了他们的新设备,有可能不支持对这款设备的支持,但是替换掉dll后应该支持了,但是老大怕这新的sdk以前的设备要是不能用怎么办,可我觉得新的sdk应该是向下兼容的吧~

   请问各位硬件高手,你们觉得我的想法对么?
--参考方法--
这个不能想当然,你应该问开发sdk的工程师,他们或许只是更改了小的bug,但也有可能做了大的改动。像我们提供sdk都是跟随linux内核的升级来做改动。
上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2014-01-05 03:18:53
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/20638/
本文WWW.DOC100.NET DOC100.NET版权所有。