欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

哪位老大装lids成功过?帮小弟我看看,小弟我的装不上

更新时间: 2014-05-16 18:27:47 责任编辑: Author_N6

 

哪位老大装lids成功过?帮我看看,我的装不上
1.我装lids时,是不是可以在高版本的linux(2.6.15)系统上编译低版本的linux+lids(2.6.10)?
网上看到编译内核时有这一步
2.
     #cd   /usr/include
          #rm   -Rf   asm   linux      
          #ln   -s   /usr/src/linux/include/asm-i386   asm
          #ln   -s   /usr/src/linux/include/linux   linux
          #ln   -s   /usr/src/linux/include/scsi   scsi
          #ln   -s   /usr/src/linux/include/asm-generic   asm-generic
这几步有必要吗?它们是什么意思?
3.我再装一遍时,发现这样:
The   next   patch   would   create   the   file   Makefile,
which   already   exists!     Assume   -R?   [n]
这个怎么办?

--参考方法--
打补丁的话,很可能就不行了。
补丁有一定的时效性。
--参考方法--
不用了吧,在2.6.15上打2.6.10的补丁,基本不好用了,kernel每一版本都会有几十万处改动,
何况内核版本差了5版,旧补丁基本不可用了。而且这样做是很危险的,要是修改了一些关键代码,
编译不通过是小事,要是编译通过,也很可能出现问题。
上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2014-05-16 18:27:47
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/666323/
本文WWW.DOC100.NET DOC100.NET版权所有。