欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

hibernate应用注意点之文件头更新

更新时间: 2014-05-18 17:21:51 责任编辑: Author_N8

 

hibernate使用注意点之文件头更新

最近下载了hibernate3.6.8进行使用,然后和struts2.2.1进行集成,结果总是报错。

 查了许久发现了如下的问题:

1.hibernate的Configuration和hbm.xml里面的文件头已经由原来的<!DOCTYPE hibernate-mapping PUBLIC "-//Hibernate/Hibernate Mapping DTD 3.0//EN"
          "http://hibernate.sourceforge.net/hibernate-mapping-3.0.dtd">

变为了

<!DOCTYPE hibernate-mapping PUBLIC
 "-//Hibernate/Hibernate Mapping DTD 3.0//EN"
 "http://www.hibernate.org/dtd/hibernate-mapping-3.0.dtd">

蓝颜色的发生了变化

2.hibernate的必须包里有slf4j-api-1.6.1.jar,所以必须要加上相对应的slf4j-log4j12-1.6.1.jar和log4j-1.2.13.jar(log4j)的包!

 3.另外和struts集成的时候要加上jpa(例如hibernate-jpa-2.0-api-1.0.1.Final.jar)的包!

上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2014-05-18 17:21:51
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/918952/
本文WWW.DOC100.NET DOC100.NET版权所有。