欢迎来到Doc100.Net免费学习资源知识分享平台!
您的位置:首页 > 程序异常 >

【转】关于“the type * is not accessible due to restriction on required library”有关问题的

更新时间: 2014-01-05 02:25:32 责任编辑: Author_N1

 

【转】关于“The type **** is not accessible due to restriction on required library”问题的

在eclipse里出现“The type **** is not accessible due to restriction on required library”的错误,大概的意思就是要导入的包被限制了。


 

解决方法:

  选中项目--右键--进入Properties(属性)视图

  选中Java Build Path--点击Libraries--展开JRE System Library[JavaSE-1.6],选中Access rules这一项(如果没有,那就是JDK安装和配置的问题)。

   Edit--点击Add--在Rule Pattern(规则式样)编辑你允许导入的类库,如本例中输入(javax/servlet/**),允许就是在Resolution选项中选中Accessible(当然,有些项目需要可以选择Forbidden、Discourage某些类库)。

   然后重启就可以了。

上一篇:上一篇
下一篇:下一篇

 

随机推荐程序问答结果

 

 

如对文章有任何疑问请提交到问题反馈,或者您对内容不满意,请您反馈给我们DOC100.NET论坛发贴求解。
DOC100.NET资源网,机器学习分类整理更新日期::2014-01-05 02:25:32
如需转载,请注明文章出处和来源网址:http://www.doc100.net/bugs/t/9655/
本文WWW.DOC100.NET DOC100.NET版权所有。